FileWave Server Setup

What server type is best for me?

The first step to begin your FileWave Evaluation is to determine your FileWave Server hosting preference. FileWave offers both a
Cloud-Hosted server and an on-premise virtualized server appliance for either Hyper-V or VMWare.

Cloud-Hosted Server

If you desire a FileWave Cloud-Hosted server and have not already received the login information, please request a Cloud-Hosted
server from your dedicated FileWave SE and they will provide you with the server's Address, Username, and Password. The FileWave
Cloud-Hosted Server will be a "production" server so that any progress you make during the evaluation will persist if you choose to
purchase FileWave.

Please note that choosing a Cloud-Hosted Server may be an additional cost depending on the licensing structure selected at the time
of your purchase. Also, to better manage the cost incurred by FileWave during your evaluation, your FileWave SE will discuss your
organization's timeline to determine the best possible start date and expiration date for your evaluation. Thank you in advance for
your understanding in regards to these matters.

Pros of FileWave's Cloud-Hosted Server

Near instant availability with limited setup time required

Managed public fully qualified domain name and SSL certificate
Ability to manage devices on any network with Internet connection
Free "hands-off" upgrades of FileWave

Guaranteed server uptime

Automated Backups

Low maintenance

On-Premise Server

If you desire to host the FileWave Server on-premise by installing on a macOS machine or virtualizing our pre-built appliance in Hyper-
V or VMWare, please continue to read the following section.

Requirements

Most steps required for an on-premise server will be in regards to your local network's infrastructure including virtual environment,
DNS, and Firewall/Content Filter. If you do not have direct access to these systems, please coordinate with your Network
Administrator or other qualified personnel before proceeding.

Before importing the FileWave Server virtual appliance we recommend setting aside a static IP and DNS name for it. This will make it
easier to move the server to another IP in the future and possible to manage off-premise devices over the Internet. Although
technically possible, it is highly unrecommended to only use an IP address to reference the FileWave Server so please configure a
valid and potentially publicly-resolvable fully qualified domain name (FQDN) for the FileWave Server.

Note that the FQDN selected must be resolvable on all network segments you plan to manage the client devices from. If you want to
manage devices both on and off your network then the same FODN must be resolvable both on and off your network. Inside your LAN
this FQDN will resolve to the internal IP address of your FileWave server. Externally that same FQDN will resolve to the public IP
address of the internet router in front of the FileWave Server. With mobile devices like iPhones and iPads that have a high possibility of
leaving your LAN, it is essential that they be able to access the FileWave Server at all times, especially when they are off-network.

Off-Premise device management via Internet

A static IP allows you to easily forward the ports used by the FileWave server to its internal IP on your LAN, ensuring that requests
from client devices are still able to reach it even when they are off-network. The following ports must be forwarded to the FileWave
Server. Some of the ports such as 20016 and 20446 are optional if IT staff will only be accessing the FileWave Admin while on the

LAN. A full listing of FileWave ports and port diagrams are available here.

FileWave Server Installation

The FileWave Server can installed onto any macOS 10.13+ machine with minimum specs of 8GB RAM / 4 CPU or virtualized in either
Hyper-V or VMWare using our pre-built virtual appliance based on CentOS or Debian. If virtualization is available, we highly
recommend using our pre-built server appliance versus a macOS machine because of the flexibility to extend allotted server
resources. When choosing a virtualization platform for your FileWave Server virtual appliance, we recommend a server platform such
as vSphere or Hyper-V over a client platform like VMware Workstation/Fusion or VirtualBox. A VM server platform does not require
that you be logged into a user session for the VM to be running. Also in the event the physical system hosting the VM server restarts
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the VMs hosted on it can also be configured start up automatically also.

Software Downloads

All software downloads outlined in the following steps can be found here. Please always select the latest version of FileWave unless

instructed otherwise by your FileWave SE.

macOS

1. Mount the FileWave_macOS_XX.X.X.dmg downloaded from the
FileWave Software Downloads page.

2. Double click the FileWave Server.pkg

3. Click Continue and then Agree to the license.

4. Click Install and enter your admin credentials to complete the
installation.

Hyper-V Linux Appliance Import

1. Extract the contents of the FileWaveServer_XX.X.X_VHD.zip file
to a convenient location, like your desktop, on your Hyper-V
system.

2. Launch Hyper-V Manager, highlight your server on the left-hand
pane, and go to Action > Import Virtual Machine.

3. Click Next, then Browse, select the folder that the FileWave
Server virtual appliance was extracted to
(e.g. FileWaveServer_XX.X.X), and click the Select
Folder button. If it reports that it can't file a VM to import follow
the instructions here.

4. Keep clicking Next until you reach the Choose Import
Type screen. Select Copy the virtual machine (create a new
unique ID).

5. Continue to click Next and then Finish to complete the VM
import.

6. Select the FileWave server VM in the list of VMs and go to Action
> Settings.

7. Click Network Adapter in the list of Hardware settings for the VM
and click the Virtual switch pull-down to connect it to your
network.

8. If there is no virtual switch available go to Action > Virtual
Switch Manager to add one. For the connection type be sure to
select External network.

VMware ESXi Linux Appliance Import

1. Log into the VMware web console on your ESXi sever, go
to Host on the left, choose Create/Register VM on the right,
select Deploy a virtual machine from an OVF or OVA file, and
click the Next button.

2. Atthe Select OVF and VMDK files screen enter a display name
for your VM.

3. Drag the FileWaveServer_.ova file into the blue field at the lower
right and click Next.

4. Select the datastore where you want to import the VM to and
click Next.

5. At the Deployment options screen select your VM Network and
choose "Thin" for Disk provisioning.

6. Click Finish to begin the VM import. You can monitor the import
by watching the Recent tasks pane in the Hosts area of the
vSphere web console. After the Upload disk and Import
VvApp tasks are done your VM should appear in the list of Virtual
Machines on the left-hand Navigator pane.

B /Volumes/FileWave

FileWave Server.pkg

Admin Server

Installer Installer

Client Booster
Installer Installer

T —————

£ Settings for FileWaveServer_11.2.2 on HPSERVER [=[=
[FileWaveserver 1122 v] 4 b [Q
8 Memory ~| @ Network Adapter
8000 MB
5} Frocessor Specify the configuration of the network adapter or remove the network adapter.
2 Virtual processors Virtual switch:
& EE De Controler 0 [Mot connectedt vl
Ca Hard Drive
disk-9.vhdx ekt 5 K
S BB 1DE Controller 1 [[] Enable virtual LAN identification
9 DD Drive chine wil use for al
None:
2 SCSI Controller
= B Network Adapter
Not connected
Hardware Acceleration Bandwidth Management
T [] Enable bandwidth management

4 New virtual machine

R4 1 Select creation type Select creation type
2 Select OVF and VMDK files How would you like to create a Virtual Machine?
3 Select storage

4 License agreements
5 Deployment options
6 Additional settings.
7 Ready to complete

Create a new virlual machine
Deploy a virtual machine from an OVF or OVA file

|Register an existing virtual machine

[£] Recent tasks al
Task ~ Target ~ itator v Queved ~ | startea ~ | Result ~ Completed v
S 1203 oot P R — R L

oot P R — R L

Upload disk - Fi Wave Sarvor. .

Import Vaop


https://kb.filewave.com/books/network-imaging-ivs/page/importing-filewave-virtual-appliance-hyper-v
https://kb.filewave.com/books/downloads

¥ New virtual machine - FileWave Server 12.0.3
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3 Select storage.
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VMware Fusion Linux Appliance Import

1. Launch Fusion and go to File > Import > Choose File.
2. Select the FileWave_Server.ova file and click Open and
then Continue.

3. Choose the path where you would like to copy the VM to and
click Save.

4. Click the Customize Settings button at the Finish screen to bring
up the settings screen for the VM.

5. Inthe Network Adapter section ensure that Connect Network
Adapter is checked and then select an Ethernet based option
under Bridged Networking.

VMware Workstation Linux Appliance
Import

1. Launch VMware Workstation and click Open a Virtual Machine in
the Home tab. Alternatively you can also go to File > Open.

2. Browse to the FileWave_Server_.ova file and click Open.

3. Change the storage path for the VM if desired and click Import.

4. Edit the network settings for the VM and ensure that
that Connect at power on is checked and that Bridged:
Connected directly to the physical network is selected.

5. Click OK.

VirtualBox Linux Appliance Import

1. Launch VirtualBox, go to File > Import Appliance, select
the FileWave_Server_.ova file, and click Open.

2. Check Reinitialize the MAC address of all network cards and
click Import.

3. Select your the FileWave server VM and click the Settings icon in
the icon bar.

4. Inthe Adapter 1 tab ensure that Enable Network
Adapter and Cable Connected are checked and that Attached
to is set to Bridged Adapter.

5. Click OK when you are done.

Debian (not appliance)

In the case maybe you need to setup your own Debian OS. This is fine to do.

Refer to the Debian section of the latest version of FileWave that is on the
Downloads page to see the commands to run to install or upgrade. It's the
same commands. One thing to note is that Webmin won't be installed, but

you could download and easily install it if desired. Aside from Webmin there

is not much different between a stock install and our Appliance.

Virtual machine names can contain up to 80 characters and they must be unique within each ESX instance.
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User Interface

Check the Downloads page for the most recent. Below is an example:

# login via ssh as root or use sudo for every line
below

# 0S Upgrades:

sudo apt update -y

sudo DEBIAN_FRONTEND=noninteractive apt-get

upgrade -y -o Dpkg::0Options::="--force-confold"
# Download and Install:
wget

https://fwdl.filewave.com/15.2.1/fwxserver_15.2.1_
amd64.deb

sudo dpkg -i ./fwxserver_15.2.1_amd64.deb

# If dependencies are not met then the below will
install them allowing for the FW server to
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install:

sudo apt-get install -f

# If you needed to use the above command for
dependencies then run the next line again.

# It will succeed once all dependencies are
handled which can take a couple of tries:
sudo dpkg -i ./fwxserver_15.2.1_amd64.deb
sudo reboot

Configuring the Linux Appliance Network Settings

Once you are done importing the FileWave Server Linux appliance, please power it on and configure the network settings using one of
the guides below. Once the network settings have been configured, please create an internal DNS A-Record to set a fully qualified
domain name (FQDN) for your FileWave Server that points to the Static IP Address configured below. If you plan on managing devices
off-network, please ensure the FODN is resolvable via the Internet and that you have the ability to obtain an SSL certificate that can
protect your FQDN.

You will find two sections below, Command Line and Webmin GUI. Please select only one of the two sections based on your
preference to configure the settings.

Please disregard this section if using a macOS FileWave Server as you will configure macOS System Preference to configure Static IP
address.

CentOS Command Line
v CentOS Command Line Networking

1. Access FileWave Server's Command Line Interface (CLI) via direct console access or SSH using the "root" user and
password "filewave".
SSH into FileWave Server

ssh root@192.168.1.85

2. Change the FileWave Server's password and take note of it in a secure location. You will not see password being typed,
press Enter when finished.
Change Password

passwd

3. Install "nano" text editor for easier modifications or use the pre-installed "vi" text editor.
Install nano

yum install -y nano

4. View current network settings obtained via DHCP and take note for next section.
IP address and Netmask

ifconfig

Gateway / Router

ip r

DNS Servers

less /etc/resolv.conf

Quit "less"

q

5. Set a Static IP address, Gateway, and Netmask for FileWave Server. You will change "BOOTPROTO" and add
"IPADDR", "NETMASK" and "GATEWAY". Change values to match your network settings and leave all prior configuration
the same.
Hyper-V

nano /etc/sysconfig/network-scripts/ifcfg-etho

VMWare / Virtualbox

nano /etc/sysconfig/network-scripts/ifcfg-ens32

Required changes (use your network settings)

BOOTPROTO=none



IPADDR=192.168.1.85
NETMASK=255.255.255.0
GATEWAY=192.168.1.1

Save and quit "nano"
Ctrl + X
y
Enter
6. Reboot the FileWave Server
Reboot FileWave Server

reboot
7. Verify DNS servers are valid.
DNS Servers

less /etc/resolv.conf

Quit "less"
q
8. If DNS server are not valid or not configured, add at least on DNS server.
Edit / Add DNS Servers

nano /etc/resolv.conf

Example "/etc/resolv.conf"

nameserver 8.8.8.8

Save and quit "nano"

Ctrl + X

y
Enter

9. Ping outside address to verify Internet access.
Ping Google.com

ping google.com
10. Change FileWave Server's timezone.

**xList available timezonesx*

FfTedatectl list-timezones

**xSet Timezonexx

F?Tedatectl set-timezone "America/Chicago"

11. Sync FileWave Server with NTP time server.

**Install NTPxx
yum install -y ntp
**Start and enable NTP*x*

systemctl start ntpd
systemctl enable ntpd

**xForce manual sync of NTPxx



systemctl stop ntpd
ntpd -gq
systemctl start ntpd

**Verify time and datexx*

date

Debian Command Line

¥ Debian Command Line Networking

5.1.4 Debian Linux Server

Changing the IP address in Debian 12, which uses systemd-networkd for network management, involves different steps
compared to CentOS. The following guide is tailored for Debian 12 servers using systemd-networkd but you could also use

Webmin on your server assuming the server comes online initially with DHCP.

For Webmin know that you will need to go to Webmin -> Webmin Configuration -> Operating System and Environment and
A make sure it's set to Debian 12.4 (Or whatever version we are at when you set up your system. You can see this with cat
/etc/debian_version on the server.

1. Disable the Old Server: Ensure the old server is turned off to free up the IP address.
2. Locate Network Interface:
First, identify the network interface you wish to configure. You can list all network interfaces using:

networkctl list

admin@ip-172-30-3-220: /etc/network$ networkctl list
IDX LINK TYPE OPERATIONAL SETUP

1 lo loopback carrier unmanaged

2 ens5 ether routable configured

2 links listed.

3. Configure Network Settings:
systemd-networkd uses individual .network files for each network interface, located in /etc/systemd/network/ .
Create or edit the network configuration file for your interface, named like 10-ethe.network (replace ethe with your
interface name).

sudo nano /etc/systemd/network/10-eth6.network

4. Configure IP Address:
Inthe .network file, add or modify the following sections:
[Match]
Name=etho

[Network]
Address=192.168.1.100/24
Gateway=192.168.1.1
DNS=8.8.8.8

DNS=8.8.4.4
LinkLocalAddressing=no
IPv6AcceptRA=NnO

Replace ethe with your actual network interface name.
Modify the Address with your new IP and subnet mask (e.g., /24 fora 255.255.255.0 netmask).
Set the Gateway and DNS entries as per your network configuration.

You'll also want to edit /etc/network/interfaces because ens192 is configured there for DHCP. That's how you might
have gotten to it via Webmin for instance. Edit the file to put a # before the 2 lines that have ens192 on them. Those 2
lines in the file will look like this after editing:
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# The primary network interface
#allow-hotplug ens192
#iface ens192 inet dhcp

5. Reload and Restart systemd-networkd:
After making changes, enable the Networkd service so interfaces come up at boot time, and reload the daemon and
restart the network:

sudo systemctl enable systemd-networkd
sudo systemctl daemon-reload

sudo systemctl restart systemd-networkd
6. Verification:
Check the status of your network interface to ensure the new settings are active:

networkctl status etho

You can also use ip addr show etho toview the IP configuration.

Webmin GUI

For Webmin on Debian know that you will need to go to Webmin -> Webmin Configuration -> Operating System and

£ Environment and make sure it's set to Debian 12.4 (Or whatever version we are at when you set up your system. You can see

10.

this with cat /etc/debian_version on the server.

At the login screen note the URL to remotely manage the server, ex: https://myorg.filwave.net:10000

If there is no IP address specified because DHCP is not available on the subnet for your FileWave Linux Appliance, login with
the username "root" with password "filewave".

Run "nmtui" at the command prompt to launch the Network Manager Text UI so you can configure the networking for the
FileWave VM appliance. You'll need to reload the IP stack with "service network restart". Skip the network configuration
steps later in the Webmin.

. Browse to this URL and log in with username "root" and password "filewave". We will change this password later.
. Browse to Hardware > System Time on the left, pick the Change timezone tab on the right, pick your time zone and

click Save. North American time zones all start with "America".

. Switch to the the Time server sync tab, enter "pool.ntp.org" in the Timeserver hostnames or addresses field,

set Synchronize on schedule? to "Yes, at times below", and click the Sync and Apply button.

. Go to System > Change Passwords on the left and select the "root" account on the right from the list of usernames. Enter a

new root password, confirm it, and click Change. Note that this will change the default password for the root account used
to log into the server from "filewave" to whatever you choose so enter a secure password that is easy for you to remember.

. Choose Networking > Network Configuration on the left, and Network Interfaces on the right. Click the blue link labeled

"ens160" or "ens32" for the Ethernet adapter. Change the IPv4 address settings to "Static configuration", enter a static IP,
enter a subnet mask, and click Save at the bottom to continue configuring the DNS and routing.

. You will no longer be able to access the Webmin UI for the FileWave servers via its old DHCP IP address. Change the

address in your browser's address bar to use the new static IP address for the FileWave server that you configured in the
previous step. Browse to Networking > Network Configuration on the left, and Hostname and DNS Client on the right. Enter
the IP address for your DNS server and click Save.

. Select Networking > Network Configuration on the left, and Routing and Gateways on the right. Pick "ens160" or "ens32"

from the Default routes pull-down, enter the default gateway address for the subnet the FileWave server is hosted on, and
click Save.

Go to S_ystem > Bootup and Shutdown_ on the left, scroll to the bottom on the right, and click the Reboot System button.
When asked to confirm if you want to reboot the system with "shutdown -r now" click the Reboot System button again.
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System Time

Set time Change timezone Time server sync

This form allows you to set the system's default time zone, which is used to
convert the system time to a human-readable format and offset.

Time Zone

+
LI

orking Change timezone to  America/Los_Angeles (Pacific)

& Hardware

* System Time

ebuin System Time

This form is for configuring the system to automatically synchronize the time with a remote server. Synchronization
will be done using the Unix time protocol or NTP, depending on which commands are installed and what the
remote system supports.

Set time Change timezone Time server sync

+ Webmin

Time Server

Networking i
Networking Timeserver hostnames or [ pool.ntp.org

Hardware addresses
« Set hardware time too

Synchronize when Yes @ No
Webmin starts?

Synchronize on schedule?” ) No |® Yes, at times below ..

Minutes Hours Days Months Weekdays
All All o All o All o All
® Selected .. ® Selected .. Selected .. Selected .. Selected ..
0 12 24 36 48 0 12 1 13 25 January Sunday
1 13 25 37 49 1 13 2 14 26 February Monday
2 14 26 38 50 2 14 3 15 27 March Tuesday
3 15 27 39 51 3 15 4 16 28 April Wednesday
4 16 28 40 52 4 16 5 17 29 May Thursday
5 17 29 41 53 5 17 6 18 30 June Friday
6 18 30 42 54 6 18 T 19 31 July Saturday
i 19 31 43 55 7 19 8 20 August
8 20 32 44 56 8 20 9 21 September
9 21 33 45 57 9 21 10 22 October
10 22 34 46 58 10 22 11 23 November

Z Sync and Apply
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Webmin Change Password

Changing Unix user password

Changing password for root (root)

New password ~ reereen

New password (again) | =s=+e==

Force user to change password at next login?
+ Change password in other modules?

22 Change

€ Return to user list

Webmin Boot Time Interface Parameters

Name ensiel
Activate at boot? ® Yes No

Mo address configured

From DHCP
From BOOTP
1Py address IPv4 address 10 10.10.40
@ Static configuration N€tMask 955 255 955 0
U Networking Broadcast @ Automatic
ewallD .
_ . IPv6 disabled
+  Metwork Configuration @ From IPv6 discovery
IPv6 addresses IPv6 address Netmask
Static configuration
64
MTU ® Default

Virtual interfaces 0 (Add virtual interface)

& Save @ Save and Apply @ Delete and Apply © Delete




&

DNS Client Options

Webmin
localhost.localdomain
Hostname
+ Update hostname in host addresses if changed?
Hosts file H
DNS :

Resolution order Local hostname %

a

a»

U Metworking

i ® None Listed ..

* Network Configuration ‘ 10.10.70.1

DNS servers Search domains

Save

Routing and Gateways

Webmin

Boot time configuration Active configuration n

This section allows you to configure the routes that are activated when the system
boots up, or when network settings are fully re-applied.

Routing configuration activated at boot time

Interface Gateway IPvE gateway

e Default routes
U Networking ens160 % [10.10.10.1]

rewallD Act as router?  Yes @ No

* Network Configuration

Interface Network Netmask Gateway
Static routes
Interface Netwaork MNetmask
Local routes
@ sSave
o webmin Start or stop the Webmin server
Webmin # Selectall # Invert selection @ Create a new systemd service

P Start M Stop =® Start On Boot n

o= Disahle On Boot =& Start Now and On Boot

o= Disable Now and On Boot

#& System

¢ Bootup and Shutdown . . . )
Click on this button to immediately reboot the system. All

C Reboot System currently logged in users will be disconnected and all services
will be re-started.

Click on this button to immediately shutdown the system. All
¢ sShutdown System services will be stopped, all users disconnected and the system
powered off (if your hardware supports it).
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